{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74878"],"ecosystem":"PyPI","epss":0.00749,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-h45m-mgcp-q388","id":"tcs_01M5KH7595F686FYJQ5H91S096","modified_at":"2026-09-02T09:00:04.173349014Z","published_at":"2026-08-17T11:16:42.330Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3757","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-h45m-mgcp-q388","https://www.vulncheck.com/advisories/openssl-encrypt-before-totp-rate-limiter-bypass"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3757","url":"https://osv.dev/vulnerability/PYSEC-2026-3757"},{"source":"nvd","source_id":"CVE-2026-74878","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74878"}],"summary":"openssl_encrypt versions before 1.4.0 use an in-memory rate limiter for TOTP brute-force protection that is not shared across workers and is lost on server restart. Attackers can distribute authentica"}