{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74879"],"ecosystem":"PyPI","epss":0.00444,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-2vhw-q7vh-7xv2","id":"tcs_01M5KH75D88TH5J128JG5YDVGM","modified_at":"2026-09-02T09:00:05.133625707Z","published_at":"2026-08-17T11:16:42.460Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3758","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-2vhw-q7vh-7xv2","https://www.vulncheck.com/advisories/openssl-encrypt-before-information-disclosure-via-ready-endpoint"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3758","url":"https://osv.dev/vulnerability/PYSEC-2026-3758"},{"source":"nvd","source_id":"CVE-2026-74879","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74879"}],"summary":"openssl_encrypt versions before 1.4.0 contain an information disclosure vulnerability in the /ready endpoint that returns full database exception strings to unauthenticated callers. Attackers can trig"}