{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74884"],"ecosystem":"PyPI","epss":0.00437,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-8jpj-w975-rwv5","id":"tcs_01M5KH75ZQNNG9A2J5RR9X28RZ","modified_at":"2026-09-02T09:00:03.067149774Z","published_at":"2026-08-17T11:16:43.130Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3761","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-8jpj-w975-rwv5","https://www.vulncheck.com/advisories/openssl-encrypt-before-path-traversal-via-plugin-id"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3761","url":"https://osv.dev/vulnerability/PYSEC-2026-3761"},{"source":"nvd","source_id":"CVE-2026-74884","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74884"}],"summary":"openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability in the _is_safe_path method where the plugin_id parameter is not sanitized before constructing the plugin config directory"}