{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74888"],"ecosystem":"PyPI","epss":0.00272,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-743f-89fg-x288","id":"tcs_01M5KH76CYFBGFG1V46CB8GG7B","modified_at":"2026-09-02T09:00:05.128831970Z","published_at":"2026-08-17T11:16:43.653Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3764","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-743f-89fg-x288","https://www.vulncheck.com/advisories/openssl-encrypt-before-non-standard-pbkdf2-key-derivation"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3764","url":"https://osv.dev/vulnerability/PYSEC-2026-3764"}],"summary":"openssl_encrypt versions before 1.4.0 use a non-standard PBKDF2 key derivation construction with iterations=1 per call in an outer loop, creating a KDF whose security properties have not been formally"}