{"action":"Upgrade langflow to 1.9.0 or later.","affected":[{"fixed":"1.9.0","introduced":"0"}],"component":"langflow","cve_ids":["CVE-2026-42048"],"ecosystem":"PyPI","epss":0.04195,"exploited":false,"fixed_versions":["1.9.0"],"ghsa_id":"GHSA-9whx-c884-c68q","id":"tcs_01M5KH77J4CZ7TZ4C1VM2K98QC","modified_at":"2026-07-13T16:15:26.989199998Z","published_at":"2026-06-29T11:50:50.263156Z","references":["https://osv.dev/vulnerability/PYSEC-2026-377","https://github.com/langflow-ai/langflow/security/advisories/GHSA-9whx-c884-c68q","https://nvd.nist.gov/vuln/detail/CVE-2026-42048","https://github.com/langflow-ai/langflow","https://pypi.org/project/langflow","https://github.com/advisories/GHSA-9whx-c884-c68q"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-377","url":"https://osv.dev/vulnerability/PYSEC-2026-377"}],"summary":"Langflow Knowledge Bases API is Vulnerable to Path Traversal"}