{"action":"Upgrade openssl-encrypt to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-74896"],"ecosystem":"PyPI","epss":0.00559,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-w7gr-9g4g-33mx","id":"tcs_01M5KH77VEE3EXT0VBZZHCHDZV","modified_at":"2026-09-02T09:00:03.068343699Z","published_at":"2026-08-17T11:16:44.787Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3771","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-w7gr-9g4g-33mx","https://www.vulncheck.com/advisories/openssl-encrypt-before-sandbox-escape-via-dunder-attribute-traversal"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3771","url":"https://osv.dev/vulnerability/PYSEC-2026-3771"},{"source":"nvd","source_id":"CVE-2026-74896","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-74896"}],"summary":"openssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in the DangerousPatternVisitor AST analyzer that fails to detect dunder attribute traversal techniques. Attackers can use _"}