{"action":"Upgrade gitpython to 3.1.59 or later.","affected":[{"fixed":"3.1.59","introduced":"0"}],"component":"gitpython","cve_ids":["CVE-2026-78678"],"ecosystem":"PyPI","epss":0.00412,"exploited":false,"fixed_versions":["3.1.59"],"ghsa_id":"GHSA-5xxx-qhh7-9287","id":"tcs_01M5KH7AZH0D191D79VD6VQ7S6","modified_at":"2026-09-03T11:00:03.883495034Z","published_at":"2026-08-25T02:16:52.313Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3788","https://www.vulncheck.com/advisories/gitpython-before-arbitrary-file-read-via-repo-blame","https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-5xxx-qhh7-9287"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3788","url":"https://osv.dev/vulnerability/PYSEC-2026-3788"},{"source":"nvd","source_id":"CVE-2026-78678","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-78678"}],"summary":"GitPython versions before 3.1.59 contain an incomplete denylist in the unsafe_git_revision_options guard that omits --contents and -S options, allowing attackers to read arbitrary files by passing the"}