{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81691"],"ecosystem":"PyPI","epss":0.00272,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-xr64-hcxg-4ghr","id":"tcs_01M5KH7TK40BMJPYWM476DWNAK","modified_at":"2026-09-03T11:00:03.952009076Z","published_at":"2026-08-27T17:20:58.993Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3797","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-xr64-hcxg-4ghr","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-credential-leakage-via-unvalidated-server-urls"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-3797","url":"https://osv.dev/vulnerability/PYSEC-2026-3797"},{"source":"nvd","source_id":"CVE-2026-81691","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-81691"}],"summary":"openssl_encrypt versions before 1.4.9 fail to validate server URLs in login and register_with_email functions, accepting unencrypted http:// URLs and unconfigured hosts. Attackers on the network path"}