{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81714"],"ecosystem":"PyPI","epss":0.00199,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-xg52-638v-jc5m","id":"tcs_01M5KH7TX9AC4G9XRD2HKWF4FJ","modified_at":"2026-09-03T11:00:05.946642329Z","published_at":"2026-08-27T17:21:01.590Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3799","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-xg52-638v-jc5m","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-plugin-signing-trust-anchor-enrollment-bypass"],"severity":{"label":"high","score":7},"sources":[{"source":"osv","source_id":"PYSEC-2026-3799","url":"https://osv.dev/vulnerability/PYSEC-2026-3799"},{"source":"nvd","source_id":"CVE-2026-81714","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-81714"}],"summary":"openssl_encrypt (pip: openssl-encrypt) versions <= 1.4.8 use suffix-tolerant fingerprint matching in enroll_trust_key when binding a plugin-signing trust anchor. An operator who confirms a short (forg"}