{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81717"],"ecosystem":"PyPI","epss":0.00118,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-8jx3-27qf-3p97","id":"tcs_01M5KH7VKBVK61B44QBWF0179K","modified_at":"2026-09-03T11:00:05.950356518Z","published_at":"2026-08-27T17:21:02.033Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3801","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-8jx3-27qf-3p97","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-integrity-bypass-via-added-files"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3801","url":"https://osv.dev/vulnerability/PYSEC-2026-3801"}],"summary":"openssl_encrypt (pip package openssl-encrypt) before 1.4.9 contains two weaknesses in the portable USB drive feature, whose threat model treats the removable drive as untrusted (attacker with physical"}