{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81719"],"ecosystem":"PyPI","epss":0.00436,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-587j-4r3v-cm2c","id":"tcs_01M5KH7W2A2ZNHH5ZM3DXNKRDV","modified_at":"2026-09-03T11:00:04.976292621Z","published_at":"2026-08-27T17:21:02.320Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3802","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-587j-4r3v-cm2c","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-remote-code-execution-via-plugin"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3802","url":"https://osv.dev/vulnerability/PYSEC-2026-3802"},{"source":"nvd","source_id":"CVE-2026-81719","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-81719"}],"summary":"openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compi"}