{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81721"],"ecosystem":"PyPI","epss":0.00581,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-7894-5gw8-69hr","id":"tcs_01M5KH7W7MZPQPGT4KRHARPTHE","modified_at":"2026-09-03T11:00:04.962932888Z","published_at":"2026-08-27T17:21:02.650Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3803","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-7894-5gw8-69hr","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-denial-of-service-via-kdf-2"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3803","url":"https://osv.dev/vulnerability/PYSEC-2026-3803"}],"summary":"openssl_encrypt before 1.4.9 fails to validate KDF cost parameters in encrypted file metadata and keystore headers, allowing attackers to trigger unbounded memory allocation. Attackers can craft malic"}