{"action":"Upgrade nltk to 3.10.3 or later.","affected":[{"fixed":"3.10.3","introduced":"0"}],"component":"nltk","cve_ids":["CVE-2026-12876"],"ecosystem":"PyPI","exploited":false,"fixed_versions":["3.10.3"],"ghsa_id":"GHSA-ff5c-cp5c-9wjf","id":"tcs_01M5KH8972RGJX18T194ANQ75H","modified_at":"2026-09-10T12:15:10.248081657Z","published_at":"2026-09-10T09:44:59.291918Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3869","https://github.com/nltk/nltk/security/advisories/GHSA-ff5c-cp5c-9wjf","https://github.com/nltk/nltk/pull/3649","https://github.com/nltk/nltk/commit/43aaca1b9024138421c97f970bf13ee19ac8129d","https://github.com/nltk/nltk","https://github.com/nltk/nltk/releases/tag/v3.10.3","https://pypi.org/project/nltk","https://github.com/advisories/GHSA-ff5c-cp5c-9wjf","https://nvd.nist.gov/vuln/detail/CVE-2026-12876"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3869","url":"https://osv.dev/vulnerability/PYSEC-2026-3869"}],"summary":"NLTK: Uncontrolled resource consumption in RecursiveDescentParser via ambiguous or left-recursive grammars"}