{"action":"Upgrade litellm to 1.40.16 or later.","affected":[{"fixed":"1.40.16","introduced":"0"}],"component":"litellm","cve_ids":["CVE-2024-5751"],"ecosystem":"PyPI","epss":0.00882,"exploited":false,"fixed_versions":["1.40.16"],"ghsa_id":"GHSA-gppg-gqw8-wh9g","id":"tcs_01M5KH8D9V1T82D606WHDF5NKP","modified_at":"2026-07-01T20:22:56.345088Z","published_at":"2026-06-29T11:50:41.762215Z","references":["https://osv.dev/vulnerability/PYSEC-2026-389","https://nvd.nist.gov/vuln/detail/CVE-2024-5751","https://github.com/BerriAI/litellm/pull/4228","https://github.com/BerriAI/litellm/commit/fcea4c22ad96b24436f196ae709f71932e84b0b8","https://github.com/berriai/litellm","https://huntr.com/bounties/ae623c2f-b64b-4245-9ed4-f13a0a5824ce","https://pypi.org/project/litellm","https://github.com/advisories/GHSA-gppg-gqw8-wh9g"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-389","url":"https://osv.dev/vulnerability/PYSEC-2026-389"}],"summary":"litellm vulnerable to remote code execution based on using eval unsafely"}