{"action":"Upgrade llama-cpp-python to 0.2.72 or later.","affected":[{"fixed":"0.2.72","introduced":"0.2.30"}],"component":"llama-cpp-python","cve_ids":["CVE-2024-34359"],"ecosystem":"PyPI","epss":0.26001,"exploited":false,"fixed_versions":["0.2.72"],"ghsa_id":"GHSA-56xg-wfcc-g829","id":"tcs_01M5KH8KM41E8KSQ8ZDZHQZTWF","modified_at":"2026-07-13T16:15:28.194881872Z","published_at":"2026-06-29T11:50:40.220486Z","references":["https://osv.dev/vulnerability/PYSEC-2026-392","https://github.com/abetlen/llama-cpp-python/security/advisories/GHSA-56xg-wfcc-g829","https://nvd.nist.gov/vuln/detail/CVE-2024-34359","https://github.com/abetlen/llama-cpp-python/commit/b454f40a9a1787b2b5659cd2cb00819d983185df","https://github.com/abetlen/llama-cpp-python","https://pypi.org/project/llama-cpp-python","https://github.com/advisories/GHSA-56xg-wfcc-g829"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-392","url":"https://osv.dev/vulnerability/PYSEC-2026-392"}],"summary":"llama-cpp-python vulnerable to Remote Code Execution by Server-Side Template Injection in Model Metadata"}