{"action":"Upgrade xinference to 2.7.0 or later.","affected":[{"fixed":"2.7.0","introduced":"0"}],"component":"xinference","cve_ids":["CVE-2026-61539"],"ecosystem":"PyPI","epss":0.01226,"exploited":false,"fixed_versions":["2.7.0"],"ghsa_id":"GHSA-x2rj-828p-hx9m","id":"tcs_01M5KH8RNY3NHVC0CVJRJRX1HF","modified_at":"2026-09-10T12:15:15.622746554Z","published_at":"2026-09-10T09:44:52.936049Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3946","https://github.com/xorbitsai/inference/security/advisories/GHSA-x2rj-828p-hx9m","https://github.com/xorbitsai/inference/pull/4786","https://github.com/xorbitsai/inference/commit/1b3d220f342ce68d34cec4586d9409d457dadc42","https://github.com/xorbitsai/inference","https://github.com/xorbitsai/inference/releases/tag/v2.7.0","https://pypi.org/project/xinference","https://github.com/advisories/GHSA-x2rj-828p-hx9m","https://nvd.nist.gov/vuln/detail/CVE-2026-61539"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"PYSEC-2026-3946","url":"https://osv.dev/vulnerability/PYSEC-2026-3946"}],"summary":"Xinference vulnerable to remote code execution via unsafe `eval()` in Llama3 tool-call parsing"}