{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81699"],"ecosystem":"PyPI","epss":0.00505,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-phmr-p567-q5g6","id":"tcs_01M5KH8YBDBPAXY44RF08VTC1P","modified_at":"2026-09-10T13:00:03.324953267Z","published_at":"2026-08-27T17:21:00.217Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3961","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-phmr-p567-q5g6","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-denial-of-service-via-unbounded-kdf-cost"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3961","url":"https://osv.dev/vulnerability/PYSEC-2026-3961"}],"summary":"openssl_encrypt versions before 1.4.9 fail to properly validate key derivation function costs in crafted files, allowing attackers to trigger unbounded memory and CPU exhaustion during pre-authenticat"}