{"action":"Upgrade openssl-encrypt to 1.4.9 or later.","affected":[{"fixed":"1.4.9","introduced":"0"}],"component":"openssl-encrypt","cve_ids":["CVE-2026-81702"],"ecosystem":"PyPI","epss":0.00187,"exploited":false,"fixed_versions":["1.4.9"],"ghsa_id":"GHSA-q8p3-7h6h-ghfr","id":"tcs_01M5KH8YGYZWY8KTAGMBXCYTN3","modified_at":"2026-09-10T13:00:03.324041945Z","published_at":"2026-08-27T17:21:00.680Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3962","https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-q8p3-7h6h-ghfr","https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-key-substitution-via-identity-load"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-3962","url":"https://osv.dev/vulnerability/PYSEC-2026-3962"},{"source":"nvd","source_id":"CVE-2026-81702","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-81702"}],"summary":"openssl_encrypt before 1.4.9 fails to re-derive and validate fingerprints when loading identities from identity.json, allowing attackers to substitute public keys in identity stores. Attackers can rep"}