{"action":"Upgrade pyspark to 3.5.8 or later.","affected":[{"fixed":"3.5.8","introduced":"3.0.0"}],"component":"pyspark","cve_ids":["CVE-2026-32773"],"ecosystem":"PyPI","epss":0.00414,"exploited":false,"fixed_versions":["3.5.8"],"ghsa_id":"GHSA-9437-39hj-3c93","id":"tcs_01M5KH8ZFDS072657RQTXJY3BE","modified_at":"2026-10-15T14:45:14.801306067Z","published_at":"2026-09-02T11:17:20.173Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3966","http://www.openwall.com/lists/oss-security/2026/09/01/4","https://lists.apache.org/thread/k36prh3oxl1z6ov7w8rpmfnt07hmzw3v","https://github.com/advisories/GHSA-9437-39hj-3c93"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-3966","url":"https://osv.dev/vulnerability/PYSEC-2026-3966"}],"summary":"There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege esca"}