{"action":"Upgrade vllm to 0.28.0 or later.","affected":[{"fixed":"0.28.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-90553"],"ecosystem":"PyPI","epss":0.00308,"exploited":false,"fixed_versions":["0.28.0"],"ghsa_id":"GHSA-3c86-2m5g-59q7","id":"tcs_01M5KH936JNMTB8NFVMZYXAFP5","modified_at":"2026-09-17T09:00:03.339947665Z","published_at":"2026-09-12T13:16:53.887Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3985","https://github.com/vllm-project/vllm/security/advisories/GHSA-3c86-2m5g-59q7","https://www.vulncheck.com/advisories/vllm-before-0.28.0-remote-code-execution-via-llavaonevision2-processor"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3985","url":"https://osv.dev/vulnerability/PYSEC-2026-3985"}],"summary":"vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers"}