{"action":"Upgrade vllm to 0.28.0 or later.","affected":[{"fixed":"0.28.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-93592"],"ecosystem":"PyPI","epss":0.00544,"exploited":false,"fixed_versions":["0.28.0"],"ghsa_id":"GHSA-25q3-v2hm-8vpf","id":"tcs_01M5KH95A46WCFZ6P0SFAYBGCG","modified_at":"2026-09-29T09:00:03.002511196Z","published_at":"2026-09-18T14:19:10.267Z","references":["https://osv.dev/vulnerability/PYSEC-2026-3997","https://www.vulncheck.com/advisories/vllm-before-0.28.0-denial-of-service-via-negative-token-id","https://github.com/vllm-project/vllm/security/advisories/GHSA-25q3-v2hm-8vpf"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-3997","url":"https://osv.dev/vulnerability/PYSEC-2026-3997"}],"summary":"vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative to"}