{"action":"Upgrade vllm to 0.30.0 or later.","affected":[{"fixed":"0.30.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-94624"],"ecosystem":"PyPI","epss":0.00434,"exploited":false,"fixed_versions":["0.30.0"],"id":"tcs_01M5KH97MR8D3HD30A77ZNTG6R","modified_at":"2026-09-30T09:15:02.782311010Z","published_at":"2026-09-21T22:17:01.280Z","references":["https://osv.dev/vulnerability/PYSEC-2026-4006","https://github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/kv_offload/tiering/p2p/control/zmq.py#L240-L260","https://github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/kv_offload/tiering/p2p/manager.py#L667-L677","https://www.vulncheck.com/advisories/vllm-through-0.29.0-denial-of-service-via-unbounded-p2p-kv-offloading-sessions","https://github.com/vllm-project/vllm/pull/51504","https://github.com/vllm-project/vllm"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2026-4006","url":"https://osv.dev/vulnerability/PYSEC-2026-4006"}],"summary":"vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can s"}