{"action":"Upgrade jupyterlab to 4.5.11 or later.","affected":[{"fixed":"4.5.11","introduced":"3.0.0"},{"fixed":"4.6.4","introduced":"4.6.0"}],"component":"jupyterlab","cve_ids":["CVE-2026-102830"],"ecosystem":"PyPI","epss":0.00261,"exploited":false,"fixed_versions":["4.5.11","4.6.4"],"ghsa_id":"GHSA-3jqq-pw4j-pqcj","id":"tcs_01M5KH9HVCNP4774KK2PXQP8Z9","modified_at":"2026-10-01T17:55:38.293412379Z","published_at":"2026-10-01T16:44:34.714662Z","references":["https://osv.dev/vulnerability/PYSEC-2026-4056","https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-3jqq-pw4j-pqcj","https://nvd.nist.gov/vuln/detail/CVE-2026-102830","https://github.com/jupyterlab/jupyterlab/commit/985a3223cd77fd4f991cd90066342a90711d70f6","https://github.com/jupyterlab/jupyterlab/commit/de324ae91346c713c4f5e5485f97b6e914e0f774","https://github.com/jupyterlab/jupyterlab/commit/f9de43dc565a1118120d466117f877a189a4ce90","https://github.com/jupyterlab/jupyterlab","https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11","https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4","https://pypi.org/project/jupyterlab","https://github.com/advisories/GHSA-3jqq-pw4j-pqcj"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-4056","url":"https://osv.dev/vulnerability/PYSEC-2026-4056"}],"summary":"JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)"}