{"action":"Upgrade vllm to 0.24.0 or later.","affected":[{"fixed":"0.24.0","introduced":"0.22.0"}],"component":"vllm","cve_ids":["CVE-2026-100652"],"ecosystem":"PyPI","epss":0.00419,"exploited":false,"fixed_versions":["0.24.0"],"ghsa_id":"GHSA-qff2-492f-9fm4","id":"tcs_01M5KHAF3JF8MWJ1NPA0ZD0BH8","modified_at":"2026-10-07T10:00:03.378975746Z","published_at":"2026-09-26T14:16:47.810Z","references":["https://osv.dev/vulnerability/PYSEC-2026-4185","https://www.vulncheck.com/advisories/vllm-0.22.0-through-0.23.0-denial-of-service-via-stop-token-ids","https://github.com/vllm-project/vllm/security/advisories/GHSA-qff2-492f-9fm4"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-4185","url":"https://osv.dev/vulnerability/PYSEC-2026-4185"}],"summary":"vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. A"}