{"action":"Upgrade vllm to 0.30.0 or later.","affected":[{"fixed":"0.30.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2026-105757"],"ecosystem":"PyPI","epss":0.00314,"exploited":false,"fixed_versions":["0.30.0"],"ghsa_id":"GHSA-85xf-c7hm-whqw","id":"tcs_01M5KHAHHKWBT7TRJP6M7B7Y6X","modified_at":"2026-10-08T10:00:02.850478893Z","published_at":"2026-10-05T23:17:02.467Z","references":["https://osv.dev/vulnerability/PYSEC-2026-4199","https://github.com/vllm-project/vllm/releases/tag/v0.30.0","https://github.com/vllm-project/vllm/security/advisories/GHSA-85xf-c7hm-whqw","https://github.com/vllm-project/vllm/commit/c55e15a44ec4127832d4a86928a356fdd9e68dbd","https://github.com/vllm-project/vllm/pull/51450"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-4199","url":"https://osv.dev/vulnerability/PYSEC-2026-4199"}],"summary":"vLLM is an inference and serving engine for large language models. Prior to 0.30.0, structured-output request failures can escape request-scoped validation and reach the EngineCore fatal-error path. A"}