{"action":"Upgrade deeptutor to 1.4.10 or later.","affected":[{"fixed":"1.4.10","introduced":"0"}],"component":"deeptutor","cve_ids":["CVE-2026-58168"],"ecosystem":"PyPI","epss":0.00412,"exploited":false,"fixed_versions":["1.4.10"],"ghsa_id":"GHSA-jg88-rvpc-qvxj","id":"tcs_01M5KHAK7GR510MMZV1VV15KS7","modified_at":"2026-10-15T14:45:05.890680056Z","published_at":"2026-10-15T10:22:43.280997Z","references":["https://osv.dev/vulnerability/PYSEC-2026-4206","https://nvd.nist.gov/vuln/detail/CVE-2026-58168","https://github.com/HKUDS/DeepTutor/pull/579","https://github.com/HKUDS/DeepTutor/commit/90046374b3dcd4f8a866d2d64a64440bc08eb2ef","https://github.com/HKUDS/DeepTutor","https://github.com/HKUDS/DeepTutor/releases/tag/v1.4.10","https://www.vulncheck.com/advisories/deeptutor-insecure-default-grants-unrestricted-mcp-tool-access-to-non-admin-users","https://pypi.org/project/deeptutor","https://github.com/advisories/GHSA-jg88-rvpc-qvxj"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-4206","url":"https://osv.dev/vulnerability/PYSEC-2026-4206"}],"summary":"DeepTutor missing MCP tool authorization allows non-admin users to invoke unrestricted tools"}