{"action":"Upgrade openstack-magnum to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"openstack-magnum","cve_ids":["CVE-2016-7404"],"ecosystem":"PyPI","epss":0.01883,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-793v-r35j-9rp9","id":"tcs_01M5KHBBG538W3M5Y7ZYRNAMFF","modified_at":"2026-07-01T20:22:59.516599Z","published_at":"2026-06-29T11:50:32.538452Z","references":["https://osv.dev/vulnerability/PYSEC-2026-437","https://nvd.nist.gov/vuln/detail/CVE-2016-7404","https://github.com/openstack/magnum/commit/e93d82e8b3bc19211efd54edc17aebdca50670c1","https://bugs.launchpad.net/magnum/+bug/1620536","https://bugzilla.suse.com/show_bug.cgi?id=998182","https://github.com/openstack/magnum","https://opendev.org/openstack/magnum/commit/0bb0d6486d6771ee21bbf897a091b1aa59e01b22","https://web.archive.org/web/20210124052053/https://www.securityfocus.com/bid/98467","https://pypi.org/project/openstack-magnum","https://github.com/advisories/GHSA-793v-r35j-9rp9"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-437","url":"https://osv.dev/vulnerability/PYSEC-2026-437"}],"summary":"Openstack Magnum Unsafe Credential Handling"}