{"action":"Upgrade pgadmin4 to 9.2 or later.","affected":[{"fixed":"9.2","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2025-2946"],"ecosystem":"PyPI","epss":0.00329,"exploited":false,"fixed_versions":["9.2"],"ghsa_id":"GHSA-2rrx-pphc-qfv9","id":"tcs_01M5KHBDK9SGA317BX7MGTHRF9","modified_at":"2026-07-01T20:22:59.859561Z","published_at":"2026-06-29T11:50:35.932459Z","references":["https://osv.dev/vulnerability/PYSEC-2026-449","https://nvd.nist.gov/vuln/detail/CVE-2025-2946","https://github.com/pgadmin-org/pgadmin4/issues/8602","https://github.com/pgadmin-org/pgadmin4/commit/1305d9910beefd0d6b4c7eb4f111f86edb1d356b","https://github.com/pgadmin-org/pgadmin4","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-2rrx-pphc-qfv9"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-449","url":"https://osv.dev/vulnerability/PYSEC-2026-449"}],"summary":"pgAdmin 4 Vulnerable to Cross-Site Scripting (XSS) via Query Result Rendering"}