{"action":"Upgrade pgadmin4 to 9.15 or later.","affected":[{"fixed":"9.15","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2026-7813"],"ecosystem":"PyPI","epss":0.00455,"exploited":false,"fixed_versions":["9.15"],"ghsa_id":"GHSA-h2x2-q2mc-24gw","id":"tcs_01M5KHBEFJYJ79S4D7C4Q6ZQDM","modified_at":"2026-07-01T20:22:59.889588Z","published_at":"2026-06-29T11:50:48.487645Z","references":["https://osv.dev/vulnerability/PYSEC-2026-452","https://nvd.nist.gov/vuln/detail/CVE-2026-7813","https://github.com/pgadmin-org/pgadmin4/pull/9830","https://github.com/pgadmin-org/pgadmin4/pull/9835","https://github.com/pgadmin-org/pgadmin4","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-h2x2-q2mc-24gw"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-452","url":"https://osv.dev/vulnerability/PYSEC-2026-452"}],"summary":"pgAdmin 4 server mode has an authorization vulnerability affecting Server Groups, Servers, Shared Servers, Background Processes, and Debugger modules"}