{"action":"Upgrade pgadmin4 to 8.4 or later.","affected":[{"fixed":"8.4","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2024-2044"],"ecosystem":"PyPI","epss":0.79465,"exploited":false,"fixed_versions":["8.4"],"ghsa_id":"GHSA-rj98-crf4-g69w","id":"tcs_01M5KHBEMQPA811F3P97GQCD0A","modified_at":"2026-07-01T20:22:59.900336Z","published_at":"2026-06-29T11:50:39.082606Z","references":["https://osv.dev/vulnerability/PYSEC-2026-453","https://nvd.nist.gov/vuln/detail/CVE-2024-2044","https://github.com/pgadmin-org/pgadmin4/issues/7258","https://github.com/pgadmin-org/pgadmin4/commit/4e49d752fba72953acceeb7f4aa2e6e32d25853d","https://github.com/pgadmin-org/pgadmin4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV","https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-rj98-crf4-g69w"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-453","url":"https://osv.dev/vulnerability/PYSEC-2026-453"}],"summary":"pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user"}