{"action":"Upgrade pgadmin4 to 9.10 or later.","affected":[{"fixed":"9.10","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2025-12762"],"ecosystem":"PyPI","epss":0.12705,"exploited":false,"fixed_versions":["9.10"],"ghsa_id":"GHSA-w2p4-p4rh-qcm3","id":"tcs_01M5KHBF3SR72NPAEMQD35MRTA","modified_at":"2026-07-01T20:22:59.909866Z","published_at":"2026-06-29T11:50:36.720081Z","references":["https://osv.dev/vulnerability/PYSEC-2026-454","https://nvd.nist.gov/vuln/detail/CVE-2025-12762","https://github.com/pgadmin-org/pgadmin4/issues/9320","https://github.com/pgadmin-org/pgadmin4/commit/1d397395f75320ca1d4ed5e9ca721c603415e836","https://github.com/pgadmin-org/pgadmin4","https://pypi.org/project/pgadmin4","https://github.com/advisories/GHSA-w2p4-p4rh-qcm3"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-454","url":"https://osv.dev/vulnerability/PYSEC-2026-454"}],"summary":"pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode"}