{"action":"Upgrade web2py to 2.14.6 or later.","affected":[{"fixed":"2.14.6","introduced":"0"}],"component":"web2py","cve_ids":["CVE-2016-10321"],"ecosystem":"PyPI","epss":0.02608,"exploited":false,"fixed_versions":["2.14.6"],"ghsa_id":"GHSA-gv85-wgxc-vc56","id":"tcs_01M5KHC6DA2XF3ST18NBKRQFVN","modified_at":"2026-07-01T20:23:11.774432Z","published_at":"2026-06-29T11:50:32.485181Z","references":["https://osv.dev/vulnerability/PYSEC-2026-569","https://nvd.nist.gov/vuln/detail/CVE-2016-10321","https://github.com/web2py/web2py/issues/1585#issuecomment-284317919","https://github.com/web2py/web2py/commit/944d8bd8f3c5cf8ae296fc03d149056c65358426","https://github.com/web2py/web2py","https://usn.ubuntu.com/4030-1","https://pypi.org/project/web2py","https://github.com/advisories/GHSA-gv85-wgxc-vc56"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-569","url":"https://osv.dev/vulnerability/PYSEC-2026-569"}],"summary":"web2py is vulnerable to password brute-force attack"}