{"action":"Upgrade airflow to 1.10.6 or later.","affected":[{"fixed":"1.10.6","introduced":"0"}],"component":"airflow","cve_ids":["CVE-2019-12417"],"ecosystem":"PyPI","epss":0.01277,"exploited":false,"fixed_versions":["1.10.6"],"ghsa_id":"GHSA-q3p4-gw7r-wqjc","id":"tcs_01M5KHCFRMDC44EQJ7JY2N3B9J","modified_at":"2026-07-06T08:11:16.165274596Z","published_at":"2026-07-02T14:13:09.589522Z","references":["https://osv.dev/vulnerability/PYSEC-2026-617","https://nvd.nist.gov/vuln/detail/CVE-2019-12417","https://github.com/apache/airflow/commit/caf1f264b845153b9a61b00b1a57acb7c320e743","https://github.com/advisories/GHSA-q3p4-gw7r-wqjc","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-216.yaml","https://lists.apache.org/thread.html/f3aa5ff9c7cdb5424b6463c9013f6cf5db83d26c66ea77130cbbe1bc@%3Cusers.airflow.apache.org%3E","https://pypi.org/project/airflow"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-617","url":"https://osv.dev/vulnerability/PYSEC-2026-617"}],"summary":"Apache Airflow vulnerable to XSS and local file disclosure"}