{"action":"Upgrade geopandas to 1.1.2 or later.","affected":[{"fixed":"1.1.2","introduced":"0"}],"component":"geopandas","cve_ids":["CVE-2025-69662"],"ecosystem":"PyPI","epss":0.0043,"exploited":false,"fixed_versions":["1.1.2"],"ghsa_id":"GHSA-6497-prx7-gpmq","id":"tcs_01M5KHCG81C1ATRW9T8BYKCMGQ","modified_at":"2026-06-10T17:01:18.172032507Z","published_at":"2026-01-30T19:16:11.967Z","references":["https://osv.dev/vulnerability/PYSEC-2026-62","https://lists.debian.org/debian-lts-announce/2026/04/msg00025.html","https://github.com/geopandas/geopandas/pull/3681","https://aydinnyunus.github.io/2025/12/27/sql-injection-geopandas/","https://github.com/advisories/GHSA-6497-prx7-gpmq"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-62","url":"https://osv.dev/vulnerability/PYSEC-2026-62"}],"summary":"SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database."}