{"action":"Upgrade calibreweb to 0.6.15 or later.","affected":[{"fixed":"0.6.15","introduced":"0"}],"component":"calibreweb","cve_ids":["CVE-2021-4170"],"ecosystem":"PyPI","epss":0.00809,"exploited":false,"fixed_versions":["0.6.15"],"ghsa_id":"GHSA-wrp6-9w7f-3wxg","id":"tcs_01M5KHCGK0FM08F1DD1046JE5J","modified_at":"2026-07-06T08:00:10.396603997Z","published_at":"2026-07-02T14:13:14.959672Z","references":["https://osv.dev/vulnerability/PYSEC-2026-620","https://nvd.nist.gov/vuln/detail/CVE-2021-4170","https://github.com/janeczku/calibre-web/commit/7ad419dc8c12180e842a82118f4866ac3d074bc5","https://github.com/janeczku/calibre-web","https://huntr.dev/bounties/ff395101-e392-401d-ab4f-579c63fbf6a0","https://pypi.org/project/calibreweb","https://github.com/advisories/GHSA-wrp6-9w7f-3wxg"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"PYSEC-2026-620","url":"https://osv.dev/vulnerability/PYSEC-2026-620"}],"summary":"calibre-web is vulnerable to Cross-site Scripting"}