{"action":"Upgrade jupyter-server to 2.18.0 or later.","affected":[{"fixed":"2.18.0","introduced":"0"}],"component":"jupyter-server","cve_ids":["CVE-2025-61669"],"ecosystem":"PyPI","epss":0.00244,"exploited":false,"fixed_versions":["2.18.0"],"ghsa_id":"GHSA-qh7q-6qm3-653w","id":"tcs_01M5KHCSV1N9D6NJSD1TX3E4PM","modified_at":"2026-05-20T09:19:02.865171Z","published_at":"2026-05-05T16:16:10.133Z","references":["https://osv.dev/vulnerability/PYSEC-2026-67","https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-qh7q-6qm3-653w"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-67","url":"https://osv.dev/vulnerability/PYSEC-2026-67"}],"summary":"Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redi"}