{"action":"Upgrade openexr to 2.2.1 or later.","affected":[{"fixed":"2.2.1","introduced":"0"}],"component":"openexr","cve_ids":["CVE-2017-9111"],"ecosystem":"PyPI","epss":0.03192,"exploited":false,"fixed_versions":["2.2.1"],"ghsa_id":"GHSA-qxh9-r8xw-7v99","id":"tcs_01M5KHD60FCB27861PR2NH5HJ1","modified_at":"2026-07-06T08:00:13.670571728Z","published_at":"2026-07-02T14:13:23.487285Z","references":["https://osv.dev/vulnerability/PYSEC-2026-728","https://nvd.nist.gov/vuln/detail/CVE-2017-9111","https://github.com/openexr/openexr/issues/232","https://github.com/openexr/openexr/pull/233","https://github.com/AcademySoftwareFoundation/openexr","https://github.com/openexr/openexr/releases/tag/v2.2.1","https://lists.debian.org/debian-lts-announce/2020/08/msg00056.html","https://usn.ubuntu.com/4148-1","https://usn.ubuntu.com/4339-1","https://www.debian.org/security/2020/dsa-4755","http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00060.html","http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00000.html","http://www.openwall.com/lists/oss-security/2017/05/12/5","https://pypi.org/project/openexr","https://github.com/advisories/GHSA-qxh9-r8xw-7v99"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-728","url":"https://osv.dev/vulnerability/PYSEC-2026-728"}],"summary":"OpenEXR invalid write"}