{"action":"Upgrade tensorflow-gpu to 2.7.1 or later.","affected":[{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-23594"],"ecosystem":"PyPI","epss":0.00144,"exploited":false,"fixed_versions":["2.7.1"],"ghsa_id":"GHSA-9x52-887g-fhc2","id":"tcs_01M5KHDAWCCX29BKEP7BFR962R","modified_at":"2026-07-13T16:42:45.697894012Z","published_at":"2026-07-02T14:13:15.201868Z","references":["https://osv.dev/vulnerability/PYSEC-2026-752","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9x52-887g-fhc2","https://nvd.nist.gov/vuln/detail/CVE-2022-23594","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/tree/274df9b02330b790aa8de1cee164b70f72b9b244/tensorflow/core/ir/importexport","https://pypi.org/project/tensorflow-gpu","https://github.com/advisories/GHSA-9x52-887g-fhc2"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-752","url":"https://osv.dev/vulnerability/PYSEC-2026-752"}],"summary":"Out of bounds read in Tensorflow"}