{"action":"Upgrade crawl4ai to 0.8.7 or later.","affected":[{"fixed":"0.8.7","introduced":"0"}],"component":"crawl4ai","cve_ids":["CVE-2026-56260","CVE-2026-56261","CVE-2026-56262","CVE-2026-56263","CVE-2026-56264","CVE-2026-56265","CVE-2026-56266"],"ecosystem":"PyPI","epss":0.00648,"exploited":false,"fixed_versions":["0.8.7"],"ghsa_id":"GHSA-365w-hqf6-vxfg","id":"tcs_01M5KHDM8JFSWQNP6P1YTX5W1Y","modified_at":"2026-07-23T15:11:34.813972531Z","published_at":"2026-06-30T23:17:29.363Z","references":["https://osv.dev/vulnerability/PYSEC-2026-798","https://github.com/advisories/GHSA-g2pv-76hm-j4x9","https://www.vulncheck.com/advisories/crawl4ai-arbitrary-javascript-execution-via-execute-js-endpoint","https://github.com/unclecode/crawl4ai"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-798","url":"https://osv.dev/vulnerability/PYSEC-2026-798"}],"summary":"Crawl4AI before 0.8.7 contains an arbitrary JavaScript execution vulnerability in the Docker API server's /execute_js endpoint, which accepts and executes arbitrary user-supplied JavaScript in the ser"}