{"action":"Upgrade powerline-gitstatus to 1.3.2 or later.","affected":[{"fixed":"1.3.2","introduced":"0"}],"component":"powerline-gitstatus","cve_ids":["CVE-2022-42906"],"ecosystem":"PyPI","epss":0.00477,"exploited":false,"fixed_versions":["1.3.2"],"ghsa_id":"GHSA-w67g-6gjv-c599","id":"tcs_01M5KHE7WG8X8GWMPNM33FSSPY","modified_at":"2026-07-07T11:45:15.889782993Z","published_at":"2026-07-07T10:17:22.618683Z","references":["https://osv.dev/vulnerability/PYSEC-2026-898","https://nvd.nist.gov/vuln/detail/CVE-2022-42906","https://github.com/jaspernbrouwer/powerline-gitstatus/issues/45","https://github.com/jaspernbrouwer/powerline-gitstatus/commit/fe8e963b3489e4cceaa2c1f26f2bcc2ef405364c","https://github.com/jaspernbrouwer/powerline-gitstatus","https://github.com/jaspernbrouwer/powerline-gitstatus/releases/tag/v1.3.2","https://lists.debian.org/debian-lts-announce/2023/01/msg00017.html","https://pypi.org/project/powerline-gitstatus","https://github.com/advisories/GHSA-w67g-6gjv-c599"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-898","url":"https://osv.dev/vulnerability/PYSEC-2026-898"}],"summary":"Powerline Gitstatus vulnerable to arbitrary code execution"}