{"action":"Upgrade drupal/oauth2_server to 2.1.0 or later.","affected":[{"fixed":"2.1.0","introduced":"0"}],"component":"drupal/oauth2_server","cve_ids":["CVE-2025-31691"],"ecosystem":"Packagist","ecosystem_qualifier":"Packagist:https://packages.drupal.org/8","epss":0.00434,"exploited":false,"fixed_versions":["2.1.0"],"ghsa_id":"GHSA-4f8q-mwgc-3mwc","id":"tcs_01M5MF7N1W12A9K3A2Q4A6WF8V","modified_at":"2026-09-10T03:46:09.150368330Z","published_at":"2025-02-26T18:35:21Z","references":["https://osv.dev/vulnerability/DRUPAL-CONTRIB-2025-020","https://www.drupal.org/sa-contrib-2025-020"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DRUPAL-CONTRIB-2025-020","url":"https://osv.dev/vulnerability/DRUPAL-CONTRIB-2025-020"},{"source":"nvd","source_id":"CVE-2025-31691","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-31691"}],"summary":"Provides OAuth2 server functionality based on the oauth2-server-php library."}