{"action":"Upgrade libxtst to 1.2.2-r1 or later.","affected":[{"fixed":"1.2.2-r1","introduced":"0"}],"component":"libxtst","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.2","exploited":false,"fixed_versions":["1.2.2-r1"],"id":"tcs_01M5N8HJQ33YKT5DPSB74WPBAF","modified_at":"2026-09-22T06:30:40.159385922Z","published_at":"2016-12-13T20:59:18.020Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2016-7951","https://security.alpinelinux.org/vuln/CVE-2016-7951"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2016-7951","url":"https://osv.dev/vulnerability/ALPINE-CVE-2016-7951"}],"summary":"Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks."}