{"action":"Upgrade org.hsqldb:hsqldb to 2.7.1 or later.","affected":[{"fixed":"2.7.1","introduced":"0"}],"component":"org.hsqldb:hsqldb","cve_ids":["CVE-2022-41853"],"ecosystem":"Maven","epss":0.05145,"exploited":false,"fixed_versions":["2.7.1"],"ghsa_id":"GHSA-77xx-rxvh-q682","id":"tcs_01M5N8HV3206JZSYR928NTE4JM","modified_at":"2023-11-08T04:10:33.219963Z","published_at":"2022-10-06T18:52:05Z","references":["https://osv.dev/vulnerability/GHSA-77xx-rxvh-q682","https://nvd.nist.gov/vuln/detail/CVE-2022-41853","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=50212#c7","https://lists.debian.org/debian-lts-announce/2022/12/msg00020.html","https://sourceforge.net/projects/hsqldb","https://www.debian.org/security/2023/dsa-5313","http://hsqldb.org/doc/2.0/guide/sqlroutines-chapt.html#src_jrt_access_control"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-77xx-rxvh-q682","url":"https://osv.dev/vulnerability/GHSA-77xx-rxvh-q682"}],"summary":"HyperSQL DataBase vulnerable to remote code execution when processing untrusted input"}