{"action":"Upgrade org.bitbucket.b_c:jose4j to 0.9.3 or later.","affected":[{"fixed":"0.9.3","introduced":"0"}],"component":"org.bitbucket.b_c:jose4j","cve_ids":["CVE-2023-31582"],"ecosystem":"Maven","epss":0.00766,"exploited":false,"fixed_versions":["0.9.3"],"ghsa_id":"GHSA-7g24-qg88-p43q","id":"tcs_01M5N8JACZQBENJ8J870EN316P","modified_at":"2026-09-10T03:49:58.667384204Z","published_at":"2023-10-25T18:32:21Z","references":["https://osv.dev/vulnerability/GHSA-7g24-qg88-p43q","https://nvd.nist.gov/vuln/detail/CVE-2023-31582","https://bitbucket.org/b_c/jose4j","https://bitbucket.org/b_c/jose4j/commits/1929fe3","https://bitbucket.org/b_c/jose4j/issues/203/insecure-support-of-setting-pbe-less-then","https://github.com/KANIXB/JWTIssues/blob/main/jose4j%20issue.md"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-7g24-qg88-p43q","url":"https://osv.dev/vulnerability/GHSA-7g24-qg88-p43q"}],"summary":"jose4j uses weak cryptographic algorithm"}