{"action":"Upgrade org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later.","affected":[{"fixed":"2.4","introduced":"0"}],"component":"org.jenkins-ci.plugins:ci-with-toad-edge","cve_ids":["CVE-2022-28145"],"ecosystem":"Maven","epss":0.00824,"exploited":false,"fixed_versions":["2.4"],"ghsa_id":"GHSA-7jh8-ghwc-82cw","id":"tcs_01M5N8JHSBN500T3T8R8TNGD35","modified_at":"2024-02-16T08:17:36.924095Z","published_at":"2022-03-30T00:00:24Z","references":["https://osv.dev/vulnerability/GHSA-7jh8-ghwc-82cw","https://nvd.nist.gov/vuln/detail/CVE-2022-28145","https://github.com/jenkinsci/ci-with-toad-edge-plugin/commit/d6b2292949d0cddf4a2981fefbf3e30d1dfcd88a","https://github.com/jenkinsci/ci-with-toad-edge-plugin","https://www.jenkins.io/security/advisory/2022-03-29/#SECURITY-1892","http://www.openwall.com/lists/oss-security/2022/03/29/1"],"severity":{"label":"high","score":8},"sources":[{"source":"osv","source_id":"GHSA-7jh8-ghwc-82cw","url":"https://osv.dev/vulnerability/GHSA-7jh8-ghwc-82cw"}],"summary":"Cross-site Scripting (XSS) vulnerability in Jenkins Continuous Integration with Toad Edge Plugin"}