{"action":"Upgrade org.apache.storm:storm-metrics-prometheus to 2.8.7 or later.","affected":[{"fixed":"2.8.7","introduced":"2.6.3"}],"component":"org.apache.storm:storm-metrics-prometheus","cve_ids":["CVE-2026-40557"],"ecosystem":"Maven","epss":0.00193,"exploited":false,"fixed_versions":["2.8.7"],"ghsa_id":"GHSA-82fm-wpc2-5pmp","id":"tcs_01M5N8KHHYHMYCCP15WD8GFRSM","modified_at":"2026-05-05T22:26:26.514305Z","published_at":"2026-04-27T15:30:52Z","references":["https://osv.dev/vulnerability/GHSA-82fm-wpc2-5pmp","https://nvd.nist.gov/vuln/detail/CVE-2026-40557","https://github.com/apache/storm","https://lists.apache.org/thread/f5bv68z1y5xstz22psjk05p3wn86knjq","http://www.openwall.com/lists/oss-security/2026/04/25/2"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-82fm-wpc2-5pmp","url":"https://osv.dev/vulnerability/GHSA-82fm-wpc2-5pmp"}],"summary":"Apache Storm Prometheus Reporter vulnerable to Improper Certificate Validation via Global SSL Context Downgrade"}