{"action":"Upgrade org.jenkins-ci.plugins:publish-over-ssh to 1.23 or later.","affected":[{"fixed":"1.23","introduced":"0"}],"component":"org.jenkins-ci.plugins:publish-over-ssh","cve_ids":["CVE-2022-23111"],"ecosystem":"Maven","epss":0.26546,"exploited":false,"fixed_versions":["1.23"],"ghsa_id":"GHSA-884c-9wwh-9p6v","id":"tcs_01M5N8M7Z60HTEBQS91MBCH25K","modified_at":"2024-02-16T08:22:26.488583Z","published_at":"2022-01-13T00:00:53Z","references":["https://osv.dev/vulnerability/GHSA-884c-9wwh-9p6v","https://nvd.nist.gov/vuln/detail/CVE-2022-23111","https://github.com/jenkinsci/publish-over-ssh-plugin/commit/21bf41adbce9e71d3f77e113e29bf81d437cadc3","https://github.com/jenkinsci/publish-over-ssh-plugin","https://github.com/jenkinsci/publish-over-ssh-plugin/releases/tag/publish-over-ssh-1.23","https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2290","http://www.openwall.com/lists/oss-security/2022/01/12/6"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-884c-9wwh-9p6v","url":"https://osv.dev/vulnerability/GHSA-884c-9wwh-9p6v"}],"summary":"CSRF vulnerability and missing permission checks in Jenkins Publish Over SSH Plugin"}