{"action":"Upgrade org.apache.ranger:ranger to 2.4.0 or later.","affected":[{"fixed":"2.4.0","introduced":"2.3.0"}],"component":"org.apache.ranger:ranger","cve_ids":["CVE-2022-45048"],"ecosystem":"Maven","epss":0.01126,"exploited":false,"fixed_versions":["2.4.0"],"ghsa_id":"GHSA-89gw-cffj-mqg9","id":"tcs_01M5N8MCNNKAX42BESB20YPTK6","modified_at":"2023-11-08T04:10:49.772346Z","published_at":"2023-07-06T21:14:54Z","references":["https://osv.dev/vulnerability/GHSA-89gw-cffj-mqg9","https://nvd.nist.gov/vuln/detail/CVE-2022-45048","https://github.com/apache/ranger","https://lists.apache.org/thread/6rpzwy1smdhr60tsh1ydknn3kdm45bb6"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-89gw-cffj-mqg9","url":"https://osv.dev/vulnerability/GHSA-89gw-cffj-mqg9"}],"summary":"Apache Ranger code execution vulnerability in policy expressions"}