{"action":"Upgrade org.apache.polaris:polaris-runtime-service to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0"}],"component":"org.apache.polaris:polaris-runtime-service","cve_ids":["CVE-2026-42809"],"ecosystem":"Maven","epss":0.00356,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-8ggj-j522-h5qf","id":"tcs_01M5N8MN089P8HDXHDT4G7GPJ5","modified_at":"2026-05-08T18:11:25.314572Z","published_at":"2026-05-04T18:30:31Z","references":["https://osv.dev/vulnerability/GHSA-8ggj-j522-h5qf","https://nvd.nist.gov/vuln/detail/CVE-2026-42809","https://github.com/apache/polaris/commit/c98d610bc8f7ee237b272e01814391838dd6abf9","https://github.com/apache/polaris","https://github.com/apache/polaris/releases/tag/apache-polaris-1.4.1","https://lists.apache.org/thread/8tfsr8y7pgq6rdcvjx95hkcr47td671r","http://www.openwall.com/lists/oss-security/2026/05/02/10"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-8ggj-j522-h5qf","url":"https://osv.dev/vulnerability/GHSA-8ggj-j522-h5qf"}],"summary":"Apache Polaris has an Improper Input Validation Issue"}