{"action":"Upgrade org.jenkins-ci.plugins:violation-comments-to-gitlab to 2.29 or later.","affected":[{"fixed":"2.29","introduced":"0"}],"component":"org.jenkins-ci.plugins:violation-comments-to-gitlab","cve_ids":["CVE-2019-10415"],"ecosystem":"Maven","epss":0.01068,"exploited":false,"fixed_versions":["2.29"],"ghsa_id":"GHSA-8hwr-589g-xpj2","id":"tcs_01M5N8MXCAW8ZTAC0YYVNEZKB6","modified_at":"2024-02-16T08:19:22.595932Z","published_at":"2022-05-24T16:56:46Z","references":["https://osv.dev/vulnerability/GHSA-8hwr-589g-xpj2","https://nvd.nist.gov/vuln/detail/CVE-2019-10415","https://github.com/jenkinsci/violation-comments-to-gitlab-plugin/commit/e8237a803012bae7773d8bd10fe02e21892be3fe","https://jenkins.io/security/advisory/2019-09-25/#SECURITY-1577","http://www.openwall.com/lists/oss-security/2019/09/25/3"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-8hwr-589g-xpj2","url":"https://osv.dev/vulnerability/GHSA-8hwr-589g-xpj2"}],"summary":"Jenkins Violation Comments to GitLab Plugin has Insufficiently Protected Credentials"}